Harmonogram projektu w Excelu (przykład)

To raczej ostateczność niż rekomendowane narzędzie do zarządzania projektami. Harmonogram projektu w Excelu może być jednak całkiem funkcjonalny i przyjazny użytkownikowi.

W tym artykule pokażę Ci co jest potrzebne, żeby arkusz kalkulacyjny automatycznie generował harmonogramy prawie jak na wykresie Gantta (prawie jednak robi różnicę).

harmonogram w excelu - przykład

Standardowe pola w harmonogramie

Zaczynamy od kilku podstawowych pól niezbędnych w każdym narzędziu do zarządzania projektami.

Pola tekstowe, niezwiązane z logiką harmonogramu (możesz dodawać dowolne inne):

  • Type – tu możesz zdefiniować kategorie zadań, np. development lub testy albo wykorzystać to pole do innych celów (albo usunąć je z harmonogramu).
  • Task – nazwa zadania lub zestawu zadań do zrobienia.
  • Responsible – kto jest odpowiedzialny za zadanie. Można tu zastosować słownik (walidację), lub wpisywać dowolny tekst.
  • Phase – faza projektu/wersja. Jak wyżej, dobry kandydat do osłownikowania.

Pola służące do generowania wykresów:

  • Start date – data rozpoczęcia zadania.
  • Original due date – planowana data zakończenia (do wyliczania czy zadanie jest opóźnione czy nie).
  • Duration – wyliczane automatycznie na podstawie dat.
  • Date delivered – faktyczna data dostarczenia.
  • Status – wartość ze słownika (do oznaczania czy zadanie jest w trakcie czy zakończone).
  • Today – data dzisiejsza z funkcji =DZIŚ(). Do rysowania linii wyznaczającej bieżący tydzień.
  • Day late – formuła wyliczająca opóźnienie zadania. Jeżeli zadanie jest zakończone, to uwzględnia datę dostarczenia (Date delivered). Jeżeli nie, to porównuje z datą bieżącą (Today).

Przykładowy widok listy zadań w harmonogramie projektu wygląda więc tak:

dane podstawowe planu projektu

Dobrą praktyką jest też zabezpieczenie komórek wyliczalnych tak, aby w przypadku pustych wartości składowych nie zwracały błędu.

Na przykład dla Days late to będzie:

=JEŻELI(CZY.TEKST(H4);"NA";JEŻELI(CZY.TEKST(F4);"NA";(JEŻELI(F4*H4>0;F4-H4;(JEŻELI(F4>0;F4-J4;"NA"))))))

Dzięki czemu w odpowiedniej komórce pojawi się „NA”, zamiast błędu.

harmonogram w Excelu - walidacje

Harmonogram projektu w Excelu – wizualizacja postępu

Teraz pora na rysowanie harmonogramu. Użyłem skali z dokładnością do tygodnia.

Bloki przedstawiające zadania utworzyłem za pomocą opcji Formatowanie warunkowe.

Data dzisiejsza

Do oznaczenia bieżącego tygodnia użyłem linii rysowanej funkcją:

=JEŻELI(M$A$1:$BA$7$2<=DZIŚ();JEŻELI(N$2>=DZIŚ();PRAWDA;FAŁSZ);FAŁSZ)

Po zastosowaniu tego formatowania do wszystkich komórek wychodzi linia wyznaczająca bieżącą datę:

harmonogram projektu w Excelu - data dzisiejsza

Zadanie zrobione lub nie, o czasie lub nie

Następnie w formatowaniu warunkowym dodałem cztery opcje:

Zadania zakończone po czasie – ciemnoczerwony kolor

=(M$2<$H4)ORAZ($H4$A:$XFD>$F4)ORAZ(NIE(CZY.TEKST($H4)))ORAZ($I4="Complete")ORAZ(M$2>$E4)

Zadania zakończone o czasie – ciemnozielony kolor

=($I4="Complete")ORAZ(M$2<$H4)ORAZ(M$2>$E4)

Zadania w trakcie, ale już przekroczone – jasnoczerwony kolor

=(M$2<$F4)ORAZ($F4ORAZ($I4<>"Complete")*ORAZ(M$2>$E4)

Zadania w trakcie i o czasie – jasnozielony kolor

=(M$2<$F4)ORAZ($I4 <>"Complete")ORAZ(M$2>$E4)

Wizualnie prezentuje to się tak:

wizualizacja postępu prac w projekcie
  • Zadanie 1 skończyło się po terminie,
  • Zadanie 2 skończyło się przed czasem,
  • Zadanie 3 trwa i nie przekroczyło terminu,
  • Zadanie 4 trwa i termin już się zakończył.

Zobacz harmonogram w akcji

Pobierz harmonogram projektu w Excelu

Plik z harmonogramem dostępny na liście materiałów do pobrania.

📥Przejdź do strony z materiałami aby pobrać arkusz (nr 9 na liście)


A może czas przesiąść się z Excela do czegoś bardziej przyjaznego w zarządzaniu zadaniami?
Sprawdź co oferuje monday.com!

Google Sheet ma też kilka pomocnych funkcji do zarządzania zadaniami.

Sprawdź z czego warto korzystać.

zarządzanie projektami przy pomocy Google Sheet

Witaj w Project Makers!

Cześć, jestem Artur.

Uruchomiłem bloga Project Makers po to, żeby pokazywać jak przy pomocy podstawowych narzędzi i zdrowego rozsądku, każdy może w krótkim czasie osiągnąć mistrzostwo w zwinnym zarządzaniu projektami.

A wszystko zaczęło się od niezaliczonych egzaminów z programowania
(czytaj dalej…)

Potrzebujesz konsultacji?
Umów BEZPŁATNE spotkanie!

bezpłatne konsultacje zarządzanie projektami

Partnerzy Project Makers

Szukasz ciekawych treści?

Najnowsze wpisy

  • All Post
  • Definiowanie wymagań
  • Narzędzia
  • Planowanie
  • Praca z celami
  • Rekomendacje
  • Rozmowy z ekspertami
  • Zarządzanie budżetem
  • Zarządzanie jakością
  • Zarządzanie zespołem

Znajdź na blogu

Szukasz ciekawych treści o Narzędziach, Automatyzacji i Wskaźnikach w Zarządzaniu Projektami?

Zapisz się do Newslettera Project Makers!
Najnowsze trendy, ciekawostki, narzędzia.
Tylko sprawdzone treści. 

Współpracuję z:

Project Makers
u. Dworcowa 8
44-240 Żory
artur@projectmakers.pl

Copyright © 2024 Project Makers